45 45 votes Consider the following clauses: Not inherently suitable for client authentication. Not a state sensitive protocol. Must be operated with more than one server. Suitable for structured message organization. May need two ports on the serve side for proper operation. The option that has the maximum number of correct matches is IMAP-i; FTP-ii; HTTP-iii; DNS-iv; POP3-v FTP-i; POP3-ii; SMTP-iii; HTTP-iv; IMAP-v POP3-i; SMTP-ii; DNS-iii; IMAP-iv; HTTP-v SMTP-i; HTTP-ii; IMAP-iii; DNS-iv; FTP-v Computer Networks gateit-2007 computer-networks network-protocols normal + – Ishrat Jahan 11.3k views answer comment Share Follow Print See all 4 Comments 4 4 Comments reply mahendrapatel commented Jan 13, 2023 reply Follow flag This question answers are more confusing 1 1 replyShare vamsi_vinay commented Aug 19, 2025 reply Follow flag FTP need 2 ports ,one for Data link layer and another for transmitting the file , so for FTP - 5th option is most close , therefore it is simply option D . Actually nothing more needed to verify correct one. 0 0 replyShare 𝓗𝓮𝓲𝓼𝓮𝓷𝓫𝓮𝓻𝓰 commented Sep 15, 2025 reply Follow flag That's the first thought came into my mind after seeing this question 0 0 replyShare ISHAN KUMRA commented 2 days ago reply Follow flag Only HTTP and DNS in current syllabus. HTTP is stateless and DNS "can" be operated in more than one server but it is "strictly" organised. only D matches. 0 0 replyShare Please log in or register to add a comment.
Best answer 13 13 votes $\text{SMTP}$ which uses $\text{SMTP-AUTH}$ for client side authentication. More read. It is wrong to say that HTTP does not provide authentication mechanism – it is just that the mechanism is not secure due to lack of encryption. More read. $\text{HTTP}$ is mostly a stateless protocol though some state mechanisms like cookies are there. More read. $\text{DNS}$ The below paragraph is take from Page 4 of RFC 1035 ”The DNS requires that all zones be redundantly supported by more than one name server. Designated secondary servers can acquire zones and check for updates from the primary server using the zone transfer protocol of the DNS.” $\text{IMAP}$ is suitable for structured message organization. The below paragraph is taken from RFC 3501. ”The Internet Message Access Protocol, Version 4rev1 (IMAP4rev1) allows a client to access and manipulate electronic mail messages on a server. IMAP4rev1 permits manipulation of mailboxes (remote message folders) in a way that is functionally equivalent to local folders. IMAP4rev1 also provides the capability for an offline client to resynchronize with the server.” $\text{FTP}$ needs two connections – one for data and another for control. The below paragraph is taken from Page 17 of RFC959. ”Both the user and the server-DTPs have a default data port. The user-process default data port is the same as the control connection port (i.e., U). The server-process default data port is the port adjacent to the control connection port (i.e., L-1).” Thus, Option D is the answer as all the five matches are correct. gatecse answered Jan 26, 2023 • selected Jan 26, 2023 by gatecse 2 flags: ✌ Edit necessary (Arjun)✌ Edit necessary (Shivam_sharma 8) gatecse comment Share Follow See 1 comment 1 1 comment reply P0535_Yedidyah_Sagar commented Aug 17, 2025 reply Follow flag @gatecseSir, According to your explanation, only 3 are matching correct in option D (and not 5 as you mentioned at the end)IMAP is wrongly matched with iii) instead of iv)DNS is wrongly matched with iv) instead of iii)Please check sir 3 3 replyShare Please log in or register to add a comment.
29 29 votes They are asking for maximum correct matches so Should be $\text{HTTP}$ thus we use $\text{HTTPS}$. $\text{HTTP}$ as it does not depend on state of device or operating system. $\text{IMAP}$ or $\text{DNS}^*$Not sure but they may involve multiple servers. $\text{POP3}$ is suitable for structuring or arranging the folders. $\text{FTP}$ needs two ports,$20$ for data and $21$ for control. Thus, Option D, As it's matching with $\text{HTTP-2,IMAP-3,FTP-5}$. Shashank Chavan answered Feb 1, 2016 • edited Jan 26, 2023 by gatecse Shashank Chavan comment Share Follow See all 9 Comments 9 9 Comments reply Show 6 previous comments Venky8 commented Apr 24, 2021 reply Follow flag @Priyansh Singh Statement (ii) is asking about statelessness. Also for the correct explanation of (ii) see this link. 0 0 replyShare Divyanshu Shukla commented Jun 5, 2021 i edited by Divyanshu Shukla Jun 5, 2021 reply Follow flag IMAP4 is suitable for message organization not POP3. Ref:Forouzan page 839. 3 3 replyShare Divyanshu Shukla commented Jun 5, 2021 reply Follow flag Should be HTTP thus we use HTTPS. HTTP or SMTP or DNS as it does not depend on the state of the device or operating system. IMAP4 or DNS as they involve multiple servers. IMAP4 is suitable for structuring or arranging folders. FTP needs two ports 20 for the data connection and 21 for the control connection. 3 3 replyShare Please log in or register to add a comment.
1 1 vote Option d. anshu answered Feb 3, 2015 anshu comment Share Follow See all 3 Comments 3 3 Comments reply Akash Kanase commented Dec 18, 2015 reply Follow flag why ? 7 7 replyShare manishkumar111 commented Jan 30, 2016 reply Follow flag I think ftp uses two ports 21 for commands and 20 for data transfer.. thats all i know. 5 5 replyShare Shashank Chavan commented Feb 1, 2016 reply Follow flag @Akash check out my answer. 1 1 replyShare Please log in or register to add a comment.
1 1 vote Option D Asking for maximum matches C :- SMTP[(ii)-stateless], DNS[(iii)-multiple servers] → 2 matchings D:- HTTP[(ii)-stateless], IMAP[(iii)-multiple servers], FTP[(v)-2 ports on server side] → 3 matchings Ashley Varghese Joy answered Dec 18, 2020 Ashley Varghese Joy comment Share Follow See 1 comment 1 1 comment reply Divyanshu Shukla commented Jun 5, 2021 reply Follow flag IMAP4 is responsible for organizing messages in folders. So, C should have 3 matchings. IMAP ● Developed after POP and attempts to fix POP deficiencies ● allows keeping all mail on the server ● allows mail categorization via folder metaphor ● mail is easily flagged (answered, draft, deleted, seen, recent); this isn’t the same on all servers ● provides for multiple connections to the server 1 1 replyShare Please log in or register to add a comment.
0 0 votes among the options http is only stateless so direct d option Kshitij_Rabadey answered Jan 13 Kshitij_Rabadey comment Share Follow 0 reply Please log in or register to add a comment.
0 0 votes COMMENT BELOW IF YOU HAVE ANY DOUBT akshay_123 answered May 2 akshay_123 comment Share Follow 0 reply Please log in or register to add a comment.